home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / gnome-base / libbonobo-2.10.1 / libbonobo-2.10.1.ebuild < prev    next >
Text File  |  2006-01-09  |  828b  |  34 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/gnome-base/libbonobo/libbonobo-2.10.1.ebuild,v 1.10 2005/12/30 16:42:13 corsair Exp $
  4.  
  5. inherit gnome2
  6.  
  7. DESCRIPTION="GNOME CORBA framework"
  8. HOMEPAGE="http://www.gnome.org/"
  9.  
  10. LICENSE="LGPL-2.1 GPL-2"
  11. SLOT="0"
  12. KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sparc x86"
  13. IUSE="debug doc static"
  14.  
  15. RDEPEND=">=dev-libs/glib-2.6
  16.     >=gnome-base/orbit-2.9.2
  17.     >=dev-libs/libxml2-2.4.20
  18.     >=dev-libs/popt-1.5
  19.     !gnome-base/bonobo-activation"
  20.  
  21. DEPEND="${RDEPEND}
  22.     >=dev-util/pkgconfig-0.9
  23.     >=dev-util/intltool-0.28
  24.     doc? ( >=dev-util/gtk-doc-1 )"
  25.  
  26. DOCS="AUTHORS ChangeLog NEWS README TODO"
  27.  
  28. USE_DESTDIR="1"
  29.  
  30.  
  31. pkg_setup() {
  32.     G2CONF="$(use_enable static) $(use_enable debug bonobo-activation-debug)"
  33. }
  34.